hdu 3466 Proud Merchants

问题描述

Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?

 

输入

There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

 

输出

For each test case, output one integer, indicating maximum value iSea could get.

 

样例输入

     
     
     
     
2 10 10 15 10 5 10 5 3 10 5 10 5 3 5 6 2 7 3
 

样例输出

   
   
   
   
5 11


假设A(p1,q1,v1),B(p2,q2,v2)。先A,所以dp[q1...m]都会更新,然后再B的时候,如果B的要调用的dp小于q1的话,就不行了。所以要先按调用的dp从小到大的顺序排序,再转化成01背包问题;

代码如下:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;

int dp[5555];
struct node
{
    int p,q,v;
}no[550];

bool cmp(node a,node b)
{
    return a.q-a.p<b.q-b.p;
}

int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
            scanf(" %d%d%d",&no[i].p,&no[i].q,&no[i].v);
        sort(no+1,no+n+1,cmp);//达到无后效性;
        for(int i=1;i<=n;i++)
            for(int j=m;j>=no[i].q;j--)
            {
            
                    dp[j]=max(dp[j],dp[j-no[i].p]+no[i].v);
            }
        printf("%d\n",dp[m]);
    }
}

你可能感兴趣的:(hdu 3466 Proud Merchants)