hdu 1312 搜索

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16057    Accepted Submission(s): 9898


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

Sample Input
   
   
   
   
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
   
   
   
   
45 59 6 13
 

正在看 搜索 简单的搜索题。

DFS  :

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#define max(a,b)(a>b?a:b)


int m,n,s,t,ans;
int vis[25][25];
char maps[25][25];
int dir[4][2]={{-1,0},{1,0},{0,1},{0,-1}};


void DFS(int x, int y)
{
    for(int i=0;i<4;i++)
    {
        int dx=x+dir[i][0];
        int dy=y+dir[i][1];
        if(x>=0 && y>=0 && x<m && y<n && maps[dx][dy]=='.' && !vis[dx][dy])
        {
            vis[dx][dy]=1;
            ans++;
            DFS(dx,dy);
        }
    }
}


int main()
{
    while(scanf("%d%d",&n,&m),n+m)
    {
         memset(maps,0,sizeof(maps));
         for(int i=0;i<m;i++)
         {
            scanf("%s",maps[i]);
         }


         for(int i=0;i<m;i++)
         {
             for(int j=0;j<n;j++)
             {
                 if(maps[i][j]=='@')
                 {
                     s=i;
                     t=j;
                 }
             }
         }
         memset(vis,0,sizeof(vis));
         ans=1;
         vis[s][t]=1;
         DFS(s,t);
         printf("%d\n",ans);
    }
    return 0;
}





BFS :


#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<cctype>
#define max(a,b)(a>b?a:b)


using namespace std;


struct point
{
    int x,y;
};


int m,n,s,t,ans;
int vis[25][25];
char maps[25][25];
int dir[4][2]={{-1,0},{1,0},{0,1},{0,-1}};


void BFS()
{
   queue<point> que;
   struct point start;
   start.x=s;
   start.y=t;
   vis[s][t]=1;
   que.push(start);
   while(!que.empty())
   {
       struct point u;
       u=que.front();
       que.pop();
       for(int i=0;i<4;i++)
       {
           int x=u.x+dir[i][0];
           int y=u.y+dir[i][1];
           if(x<0 || y<0 || x>=m || y>=n || maps[x][y]=='#' || vis[x][y]) continue;
           vis[x][y]=1;
           ans++;
           struct point next;
           next.x =x;
           next.y =y;
           que.push(next);
       }
   }
}


int main()
{
    while(scanf("%d%d",&n,&m),n+m)
    {
         memset(maps,0,sizeof(maps));
         for(int i=0;i<m;i++)
         {
            scanf("%s",maps[i]);
         }


         for(int i=0;i<m;i++)
         {
             for(int j=0;j<n;j++)
             {
                 if(maps[i][j]=='@')
                 {
                     s=i;
                     t=j;
                 }
             }
         }
         ans=1;
         BFS();
         memset(vis,0,sizeof(vis));
         printf("%d\n",ans);
    }
    return 0;
}



你可能感兴趣的:(hdu 1312 搜索)