不可重叠:
剪花布条
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14534 Accepted Submission(s): 9196
Problem Description
一块花布条,里面有些图案,另有一块直接可用的小饰条,里面也有一些图案。对于给定的花布条和小饰条,计算一下能从花布条中尽可能剪出几块小饰条来呢?
Input
输入中含有一些数据,分别是成对出现的花布条和小饰条,其布条都是用可见ASCII字符表示的,可见的ASCII字符有多少个,布条的花纹也有多少种花样。花纹条和小饰条不会超过1000个字符长。如果遇见#字符,则不再进行工作。
Output
输出能从花纹布中剪出的最多小饰条个数,如果一块都没有,那就老老实实输出0,每个结果之间应换行。
Sample Input
Sample Output
/*------------------Header Files------------------*/
#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <cstdlib>
#include <ctype.h>
#include <cmath>
#include <stack>
#include <queue>
#include <deque>
#include <map>
#include <vector>
#include <set>
#include <limits.h>
using namespace std;
/*------------------Definitions-------------------*/
#define LL long long
#define uLL unsigned long long
#define PI acos(-1.0)
#define INF 0x3F3F3F3F
#define MOD 1000000007
#define MAX 105
#define lson rt<<1,l,m
#define rson rt<<1|1,m+1,r
/*---------------------Work-----------------------*/
string s,t;
int lens,lent;
int _next[1050];
void getnext()
{
int i=0,j=-1;
_next[0]=-1;
while(i<lent)
{
if(j==-1||t[i]==t[j])
{
i++,j++;
_next[i]=j;
}
else j=_next[j];
}
}
int KMP()
{
int i=0,j=0,cnt=0;
while(i<lens)
{
if(j==-1||s[i]==t[j]) i++,j++;
else j=_next[j];
if(j==lent) cnt++,j=0;
}
return cnt;
}
void work()
{
while(cin>>s)
{
if(s[0]=='#') break;
cin>>t;
lens=s.length();
lent=t.length();
getnext();
printf("%d\n",KMP());
}
}
/*------------------Main Function------------------*/
int main()
{
//freopen("test.txt","r",stdin);
work();
return 0;
}
可重叠:
Oulipo
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9719 Accepted Submission(s): 3851
Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
一开始和上面一样用的string,于是用cin读入,结果两次TLE,原因在于字符串长度可能很大,读入超时,然后改成字符数组+scanf读入就不超时了。
/*------------------Header Files------------------*/
#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <cstdlib>
#include <ctype.h>
#include <cmath>
#include <stack>
#include <queue>
#include <deque>
#include <map>
#include <vector>
#include <set>
#include <limits.h>
using namespace std;
/*------------------Definitions-------------------*/
#define LL long long
#define uLL unsigned long long
#define PI acos(-1.0)
#define INF 0x3F3F3F3F
#define MOD 1000000007
#define MAX 105
#define lson rt<<1,l,m
#define rson rt<<1|1,m+1,r
/*---------------------Work-----------------------*/
char s[1000050],t[10050];
int lens,lent;
int _next[10050];
void getnext()
{
int i=0,j=-1;
_next[0]=-1;
while(i<lent)
{
if(j==-1||t[i]==t[j])
{
i++,j++;
_next[i]=j;
}
else j=_next[j];
}
}
int KMP()
{
int i=0,j=0,cnt=0;
while(i<lens)
{
if(j==-1||s[i]==t[j]) i++,j++;
else j=_next[j];
if(j==lent) cnt++,j=_next[j];
}
return cnt;
}
void work()
{
int T; cin>>T;
while(T--)
{
getchar();
scanf("%s%s",t,s);
lens=strlen(s);
lent=strlen(t);
getnext();
printf("%d\n",KMP());
}
}
/*------------------Main Function------------------*/
int main()
{
//freopen("test.txt","r",stdin);
work();
return 0;
}