区间DP-POJ-3186-Treats for the Cows

Treats for the Cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4746 Accepted: 2445
Description

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.

The treats are interesting for many reasons:
The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.
Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains the value of treat v(i)
Output

Line 1: The maximum revenue FJ can achieve by selling the treats
Sample Input

5
1
3
1
5
2
Sample Output

43
Hint

Explanation of the sample:

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2).

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.
Source

USACO 2006 February Gold & Silver

题意是一个人有N个treat,把它们有序的排成一排放在仓库里,分别有各自对应的价值v[1~N],每天要取出一个卖掉,每次只能从头或尾取出一个,并且卖出的价值等于其本身价值乘以储存天数,即v[i]*age[i]。
问最终卖完后能得到的最大钱数。
貌似是区间DP。
用dp[head][tail]表示在还剩下head+1~tail这么多treats时,能够得到的最大钱数,那么很容易能得出dp方程。

dp[head][tail]=max(dp[head-1][tail]+v[head]*(N-(tail-head)),dp[head][tail+1]+v[tail+1]*(N-(tail-head)))
//
// main.cpp
// 基础DP1-O-Treats for the Cows
//
// Created by 袁子涵 on 15/10/28.
// Copyright © 2015年 袁子涵. All rights reserved.
//
// 188ms 18600KB

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
#include <algorithm>

#define MAX 2005

using namespace std;
int v[MAX],N,dp[MAX][MAX],out=0;
bool visit[MAX][MAX];
int DP(int head,int tail)
{
    if (head<0 || tail >N) {
        return 0;
    }
    if (visit[head][tail]) {
        return dp[head][tail];
    }
    dp[head][tail]=max(DP(head-1,tail)+v[head]*(N-(tail-head)),DP(head,tail+1)+v[tail+1]*(N-(tail-head)));
    visit[head][tail]=1;
    return dp[head][tail];
}

int main(int argc, const char * argv[]) {
    cin >> N;
    for (int i=1; i<=N; i++) {
        cin >> v[i];
    }
    memset(visit, 0, sizeof(visit));
    for (int i=1; i<=N; i++) {
        out=max(out,DP(i, i));
    }
    cout << out << endl;
    return 0;
}

你可能感兴趣的:(c,dp)