uva 10020 Minimal coverage

原题:
Given several segments of line (int the X axis) with coordinates [Li, Ri]. You are to choose the minimal amount of them, such they would completely cover the segment [0, M].
Input
The first line is the number of test cases, followed by a blank line.
Each test case in the input should contains an integer M (1 ≤ M ≤ 5000), followed by pairs “Li Ri”
(|Li|, |Ri| ≤ 50000, i ≤ 100000), each on a separate line. Each test case of input is terminated by pair
‘0 0’.
Each test case will be separated by a single line.
Output
For each test case, in the first line of output your programm should print the minimal number of line
segments which can cover segment [0, M]. In the following lines, the coordinates of segments, sorted
by their left end (Li), should be printed in the same format as in the input. Pair ‘0 0’ should not be
printed. If [0, M] can not be covered by given line segments, your programm should print ‘0’ (without
quotes).
Print a blank line between the outputs for two consecutive test cases.
Sample Input
2
1
-1 0
-5 -3
2 5
0 0
1
-1 0
0 1
0 0
Sample Output
0

1
0 1
大意:
首先给你一个数t,告诉你有多少个测试样例,然后给你一个数m表示区间[0,m]。然后下面给你几对区间[li,ri],当区间为0,0时输入结束。现在问你用最少的区间去覆盖[0,m]。

#include<iostream>
#include<algorithm>
#include<map>
#include<string>
#include<cstring>
#include<sstream>
#include<cstdio>
#include<vector>
#include<cmath>
#include<stack>
#include<queue>
#include<iomanip>
#include<set>
#include<fstream>
#include <climits>
using namespace std;
//fstream input,output;

struct seg
{
    int s,e;
};
seg s[100001];
int m;
vector<int> ans;
int cmp(const seg &a,const seg &b)
{
    return a.s<b.s;
}
int main()
{
    ios::sync_with_stdio(false);
    int t,a,b,index,last,w;
    cin>>t;
    while(t--)
    {
        last=index=0;
        cin>>m;
        ans.clear();
        while(cin>>a>>b)
        {
            if(a==0&&b==0)
                break;
            if(b>0&&a<m)
            {
                s[index].s=a;
                s[index].e=b;
                index++;
            }
        }
        sort(s,s+index,cmp);
        int tmp=-1;
        int i=0;
        while(true)
        {
            w=m;
            if(i>=index)
                break;
            while(i<index&&s[i].s<=last)
            {
                if(m-s[i].e<w)
                {
                    tmp=i;
                    w=m-s[i].e;
                }
                i++;
            }
            if(tmp==-1)
            {
                i++;
                continue;
            }
            ans.push_back(tmp);
            last=s[tmp].e;
            if(s[tmp].e>=m||i>=index)
                break;
        }
        if(ans.size()==0)
            cout<<0<<endl;
        else
        {
            cout<<ans.size()<<endl;
            for(int i=0;i<ans.size();i++)
            {
                cout<<s[ans[i]].s<<" "<<s[ans[i]].e<<endl;
            }
        }
        if(t>0)
        cout<<endl;
    }
// input.close();
// output.close();
    return 0;
}




解答:
明显的贪心问题,一般的区间贪心问题就是把区间按照其中一个短点或者是长度进行排序,然后每次寻找最接近目标的选项即可。此题也是如此,可以先按照起点从小到大进行排序,然后每次选择小区间末尾距离m点最近的那个区间,同时要保证当前的起点能和上一次选择的区间的末尾连接上即可。

你可能感兴趣的:(uva,贪心)