Description
给出三个整数a,b,c,输出ax^2+bx+c=0的两个解,保证方程有两个不同的实数解
Input
三个整数a,b,c(-1000<=a,b,c<=1000)
Output
输出方程的两个解,先输出较大的解
Sample Input
1 30 200
Sample Output
-10.000000000000000
-20.000000000000000
Solution
简单题
Code
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
double a,b,c;
int main()
{
while(~scanf("%lf%lf%lf",&a,&b,&c))
{
double x1=(-b+sqrt(b*b-4*a*c))/(2*a),x2=(-b-sqrt(b*b-4*a*c))/(2*a);
if(a<0)swap(x1,x2);
printf("%.6lf\n%.6lf\n",x1,x2);
}
return 0;;
}