Bone Collector
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19446 Accepted Submission(s): 7706
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 2
31).
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
Author
Teddy
Source
HDU 1st “Vegetable-Birds Cup” Programming Open Contest
Recommend
lcy
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2602
//二维数组实现01背包
//用二维数组实现有个大坑 特大的坑 坑死了
#include<cstring>
#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
#define N 1005
int vol[N];
int val[N];
int dp[N][N];
int main ()
{
int T;
scanf("%d", &T);
while(T--)
{
int n, v;
scanf("%d%d", &n, &v);
for(int i = 1; i <= n; i++)
scanf("%d", &val[i]);
for(int i = 1; i <= n; i++)
scanf("%d", &vol[i]);
memset(dp, 0, sizeof(dp));
for(int i = 1; i <= n; i++)
for(int j =0;j<=v; j++) //注意要从0开始,这个题测试数据有点变态,有的骨头有价值,但占的空间是0
{
if(j-vol[i]>=0)
dp[i][j] = max(dp[i-1][j], dp[i-1][j-vol[i]]+val[i]);
else
dp[i][j]=dp[i-1][j];
}
printf("%d\n",dp[n][v]);
}
return 0;
}
//一维数组实现01背包
#include<cstdio>
#include<cstring>
#define N 1005
#define max(a, b) (a) > (b) ? (a) : (b)
int val[N];
int vol[N];
int dp[N];
int main ()
{
int T, n, v;
scanf("%d", &T);
while(T--)
{
scanf("%d %d", &n, &v);
for(int i = 0; i < n; i++)
scanf("%d", &val[i]);
for(int i = 0; i < n; i++)
scanf("%d", &vol[i]);
memset(dp,0,sizeof(dp));
for(int i = 0; i < n; i++)
for(int j = v; j >= vol[i]; j--)
dp[j] = max(dp[j], dp[j - vol[i]] + val[i]);
printf("%d\n", dp[v]);
}
return 0;
}