http://poj.org/problem?id=1328
Description
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
Figure A Sample Input of Radar Installations
Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.
The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1
1 2
0 2
0 0
Sample Output
Case 1: 2
Case 2: 1
网上的详解
我只说一句话:注意文章中那些变量一定要定义成double
我的代码:
#include <stdio.h>
#include <algorithm>
#include <cmath>
#include <string.h>
#include <iostream>
using namespace std;
struct A
{
double l,r;
};
int cmp(const A &a,const A &b)
{
if(a.r==b.r)
return a.l>b.l;
return a.r < b.r;
}
int main()
{
int n,d,t=1;
while(~scanf("%d%d",&n,&d))
{
if(n==0&&d==0)
break;
A p[1005];
int flag=1;
int x,y;
for(int i=0; i<n; i++)
{
scanf("%d%d",&x,&y);
if(y<=d)
{
p[i].l=x-sqrt((double)d*d-(double)y*y);
p[i].r=x+sqrt((double)d*d-(double)y*y);
}
else
flag=0;
}
if(!flag)
{
cout<<"Case "<<t++<<": "<<-1<<endl;
continue;
}
sort(p,p+n,cmp);
int sum=1;
double end=p[0].r;
for(int i=1; i<n; i++)
{
if(end<p[i].l)
{
end=p[i].r;
sum++;
}
}
printf("Case %d: %d\n",t++,sum);
}
return 0;
}