DP-POJ-2533-Longest Ordered Subsequence

Longest Ordered Subsequence
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 40403 Accepted: 17793
Description

A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence (a1, a2, …, aN) be any sequence (ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input

7
1 7 3 5 9 4 8
Sample Output

4
Source

Northeastern Europe 2002, Far-Eastern Subregion

太水了。。。我都不好意思水博客,不过还是水了。
就是最长上升子序列。

//
// main.cpp
// 基础DP1-N-Longest Ordered Subsequence
//
// Created by 袁子涵 on 15/10/24.
// Copyright © 2015年 袁子涵. All rights reserved.
//
// 0ms 716KB

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>

using namespace::std;

int num[1005],dp[1005],n,out;

int main(int argc, const char * argv[]) {
    scanf("%d",&n);
    num[0]=-1;
    for (int i=1; i<=n; i++) {
        scanf("%d",&num[i]);
    }
    out=1;
    for (int i=1; i<=n; i++) {
        dp[i]=1;
        for (int j=1; j<i; j++) {
            if (num[j]<num[i]) {
                dp[i]=max(dp[j]+1,dp[i]);
            }
        }
        out=max(out,dp[i]);
    }
    printf("%d\n",out);
    return 0;
}

你可能感兴趣的:(c,dp)