1001_Alisha’s Party_2015 ACM/ICPC Asia Regional Changchun Online(优先队列)

Time Limit: 3000/2000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2199 Accepted Submission(s): 586

Problem Description

Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v, and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let p people enter her castle. If there are less than p people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query n Please tell Alisha who the n−th person to enter her castle is.

Input

The first line of the input gives the number of test cases, T , where 1≤T≤15.

In each test case, the first line contains three numbers k,m and q separated by blanks. k is the number of her friends invited where 1≤k≤150,000. The door would open m times before all Alisha’s friends arrive where 0≤m≤k. Alisha will have q queries where 1≤q≤100.

The i−th of the following k lines gives a string Bi, which consists of no more than 200 English characters, and an integer vi, 1≤vi≤108, separated by a blank. Bi is the name of the i−th person coming to Alisha’s party and Bi brings a gift of value vi.

Each of the following m lines contains two integers t(1≤t≤k) and p(0≤p≤k) separated by a blank. The door will open right after the t−th person arrives, and Alisha will let p friends enter her castle.

The last line of each test case will contain q numbers n1,…,nq separated by a space, which means Alisha wants to know who are the n1−th,…,nq−th friends to enter her castle.

Note: there will be at most two test cases containing n>10000.

Output

For each test case, output the corresponding name of Alisha’s query, separated by a space.

Sample Input

1
5 2 3
Sorey 3
Rose 3
Maltran 3
Lailah 5
Mikleo 6
1 1
4 2
1 2 3

Sample Output

Sorey Lailah Rose

Source

2015 ACM/ICPC Asia Regional Changchun Online

题很简单,就是有个坑,Alisha放人进门的时间不一定是递增的,需要先排一下序,在这里Wrong了一下。一开始没看到输入最后的那个note,在那里也Wrong了一次。可惜这是在比赛结束后才做的题QAQ,早知道这么水就先做这题了QAQ。

代码

#include <iostream>
#include <algorithm>
#include <queue>
#include <cstdio>
#include <cstring>

using namespace std;

struct node
{
    int gift;
    int index;
    char name[250];
    bool operator <(const node b)const
    {
        if(gift!=b.gift)
            return gift<b.gift;
        return index>b.index;
    }
}friends[150100];

struct enter
{
    int t,p;
    bool operator <(const enter b)const
    {
        return t<b.t;
    }
}e[150100];

int main()
{
    int TT,k,m,q;
    int ans[150100];
    scanf("%d",&TT);
    while(TT--)
    {
        priority_queue<node> que;
        scanf("%d%d%d",&k,&m,&q);
        for(int i=0;i<k;i++)
        {
            scanf("%s %d",friends[i].name,&friends[i].gift);
            friends[i].index=i+1;
        }
        int cnt=0,c=0;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&e[i].t,&e[i].p);
        }
        sort(e,e+m);
        for(int i=0;i<m;i++)
        {
            while(cnt<e[i].t)
                que.push(friends[cnt++]);
            while(e[i].p--)
            {
                if(que.size())
                {
                    ans[c++]=que.top().index;
                    que.pop();
                }
                else
                    break;
            }
        }
        while(cnt<k)
            que.push(friends[cnt++]);
        while(que.size())
        {
            ans[c++]=que.top().index;
            que.pop();
        }
        int n;
        while(q--)
        {
            scanf("%d",&n);
            printf("%s",friends[ans[n-1]-1].name);
            if(q==0) printf("\n");
            else printf(" ");
        }
    }
    return 0;
}

你可能感兴趣的:(1001_Alisha’s Party_2015 ACM/ICPC Asia Regional Changchun Online(优先队列))