Ice_cream's world I

Time Limit : 3000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)

Total Submission(s) : 55   Accepted Submission(s) : 37

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.

Input

In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.

Output

Output the maximum number of ACMers who will be awarded.
One answer one line.

Sample Input

8 10
0 1
1 2
1 3
2 4
3 4
0 5
5 6
6 7
3 6
4 7

Sample Output

3
 
  
 
  
#include<stdio.h>  
int a[100100];  
int flag;  
int find(int x)  
{  
    int r=x;  
    while(r!=a[r])  
        r=a[r];  
    a[x]=r;  
    return r;  
}  
void join(int c,int b)  
{  
    int fc=find(c);  
    int fb=find(b);  
    if(fc!=fb)  
    a[fc]=fb;  
    else  
    flag++;
}  
int main()  
{  
    int i,j,k,c,d;  
    while(scanf("%d%d",&c,&d)!=EOF)  
    {  
        for(i=0;i<c;i++)  
        {  
            a[i]=i;  
        }  
        flag=0;  
		for(i=0;i<d;i++) 
		{
	    	scanf("%d%d",&j,&k);	
		    join(j,k);  
        }
		printf("%d\n",flag);  
    }  
    return 0;  
}  


你可能感兴趣的:(Ice_cream's world I)