HDU 5240:Exam【排序】

Exam
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit  Status  Practice  HDU 5240
Appoint description:  System Crawler  (2015-11-07)

Description

As this term is going to end, DRD needs to prepare for his final exams. 

DRD has  n  exams. They are all hard, but their difficulties are different. DRD will spend at least  r_i  hours on the  i -th course before its exam starts, or he will fail it. The  i -th course's exam will take place  e_i  hours later from now, and it will last for  l_i  hours. When DRD takes an exam, he must devote himself to this exam and cannot (p)review any courses. Note that DRD can review for discontinuous time.

So he wonder whether he can pass all of his courses. 

No two exams will collide. 
 

Input

First line: an positive integer  T \leq 20  indicating the number of test cases. 
There are T cases following. In each case, the first line contains an positive integer  n \leq 10^5 , and  n  lines follow. In each of these lines, there are 3 integers  r_i, e_i, l_i , where  0 \leq r_i, e_i, l_i \leq 10^9

 

Output

For each test case: output ''Case #x: ans'' (without quotes), where  x  is the number of test cases, and  ans  is ''YES'' (without quotes) if DRD can pass all the courses, and otherwise ''NO'' (without quotes). 

 

Sample Input

      
      
      
      
2 3 3 2 2 5 100 2 7 1000 2 3 3 10 2 5 100 2 7 1000 2
 

Sample Output

      
      
      
      
Case #1: NO Case #2: YES
AC—code:
#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
using namespace std;
struct Eage
{
	int v,t,l;
}eage[100005];
int cmp(const void *a,const void *b)
{
	return (*(Eage *)a).t-(*(Eage *)b).t;
}
int main()
{
	int n,i,sum,j,t,flag;
	scanf("%d",&t);
	for(j=1;j<=t;j++)
	{
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			scanf("%d%d%d",&eage[i].v,&eage[i].t,&eage[i].l);
		}
		qsort(eage,n,sizeof(eage[0]),cmp);
		sum=flag=0;
		for(i=0;i<n;i++)
		{
			if(eage[i].v>eage[i].t-sum)
			{
				flag=1;
				break;
			}
			else
				sum=sum+eage[i].l+eage[i].v;
		}
		if(!flag)
			printf("Case #%d: YES\n",j);
		else
			printf("Case #%d: NO\n",j);
	}
	return 0;
}


你可能感兴趣的:(HDU 5240:Exam【排序】)