南邮 OJ 1090 Rock, Paper, Scissors

Rock, Paper, Scissors

时间限制(普通/Java) :  1500 MS/ 10000 MS          运行内存限制 : 65536 KByte
总提交 : 241            测试通过 : 115 

比赛描述

Rock, Paper, Scissors is a classic hand game for two people. Each participant holds out either a fist (rock), open hand (paper), or two-finger V (scissors). If both players show the same gesture, they try again. They continue until there are two different gestures. The winner is then determined according to the table below:
 
Rock beats Scissors    
Paper beats Rock    
Scissors beats Paper  
Your task is to take a list of symbols representing the gestures of two players and determine how many games each player wins.
In the following example:

Turn     : 1 2 3 4 5
Player 1 : R R S R S
Player 2 : S R S P S
Player 1 wins at Turn 1 (Rock beats Scissors), Player 2 wins at Turn 4 (Paper beats Rock), and all the other turns are ties.



输入

The input contains between 1 and 20 pairs of lines, the first for Player 1 and the second for Player 2. Both player lines contain the same number of symbols from the set {'R', 'P', 'S'}.  The number of symbols per line is between 1 and 75, inclusive.  A pair of lines each containing the single character 'E' signifies the end of the input.

输出

For each pair of input lines, output a pair of output lines as shown in the sample output, indicating the number of games won by each player.

样例输入

RRSRS
SRSPS
PPP
SSS
SPPSRR
PSPSRS
E
E

样例输出

P1: 1
P2: 1
P1: 0
P2: 3
P1: 2
P2: 1

题目来源

ACM Mid-Central Regional 2009




#include<iostream>
#include<string>
using namespace std;

int RPS(const char& c1,const char& c2){
	if(c1=='R'&&c2=='S' || c1=='S'&&c2=='P' || c1=='P'&&c2=='R')
		return 1;
	else if(c2=='R'&&c1=='S' || c2=='S'&&c1=='P' || c2=='P'&&c1=='R')
		return -1;
	else
		return 0;
}
int main(){
	string str1,str2;
	int i,P1win,P2win;
	while(cin>>str1>>str2 && str1[0]!='E'){
		P1win = 0;
		P2win = 0;
		for(i=0;i<(int)str1.size();++i){
			if(RPS(str1[i],str2[i])==1)
				++P1win;
			else if(RPS(str1[i],str2[i])==-1)
				++P2win;
		}
		cout<<"P1: "<<P1win<<endl;
		cout<<"P2: "<<P2win<<endl;
	}
}





你可能感兴趣的:(ACM,Paper,rock,南邮OJ,Scissors)