WHOJ 1606 - Funny Sheep【水】

Problem 1606 - Funny Sheep
Time Limit: 1000MS    Memory Limit: 65536KB   
Total Submit: 616   Accepted: 172   Special Judge: No
Description

There are N+1 rows and M+1 columns fence with N*M grids on the grassland. Each grid has a sheep. In order to let the sheep together, we need to dismantle the fence. Every time you can remove a row or a column of fences. What’s the least number of times to reach the goal? 

Input
There are multiple test cases.
The first line of each case contains two integers N and M. (1≤N,M≤1000)
Output
For each case, output the answer in a line.
Sample Input
1 2
2 2
Sample Output

2
AC-code:
#include<cstdio>
int main()
{
	int n,m;
	while(~scanf("%d%d",&m,&n))
	{
		if(m==n&&n==1)
		{
			printf("0\n");
		 } 
		 else
		 	printf("%d\n",n<m?n:m);
	}
	return 0;
}


你可能感兴趣的:(WHOJ 1606 - Funny Sheep【水】)