NOJ——[1438] Get Up, Soldier!

  • 问题描述
  • 小日本真是越来越嚣张了,不过我军也不是吃素的。为了能够痛击小日本,我军决定近日举行一个军事演习,演戏的方式是红蓝两军在长城两侧对峙,双方都想要拿下对方阵地。目前双方正僵持在长城上。作为蓝军司令,你迫切想要知道长城上的战况。为简单起见,假设长城是一维的,坐标从1到n。你的部下每一次都会送来一个情报:从X到Y位置的战况被逆转了。这个逆转的意思就是,假如这个位置本是蓝军占领,那么现在被红军占领了,反之亦然。另外你随时想要知道某个位置的战况如何。作为一个ACMer司令,当然要占点优势,所以最开始长城线全被蓝军占领了。
  • 输入
  • 有多组输入。每组第一行为两个数字n(1<=n<=80000)和m(1<=m<=40000),代表长城长度和m次的询问。接下来是m行,每行开头为q或者s,s代表士兵的汇报,q代表司令的询问,具体数字含义请参照描述。
  • 输出
  • 对于每组的每个q询问,请输出结果,0代表蓝军,1代表红军。
  • 样例输入
  • 3 3
    q 1
    s 1 2
    q 2
    
  • 样例输出
  • 0
    1
    
  • 提示
  • 来源
  • 小白菜(shengrui)
线段树搞定!

#include<stdio.h>
#include<string.h>

const int maxn=80010;

struct node
{
int l,r,add;//add=1代表战况反转,否则不翻转
bool status;
}tree[maxn<<2];

void pushdown(int p)
{
if(tree[p].add==1) //反转
{
tree[p<<1].add^=1;//当前要反转的话,子节点果断要反转,所以如果子节点本来就要反转,那么反转2次等于没反转。
tree[p<<1|1].add^=1;
tree[p<<1].status^=1;
tree[p<<1|1].status^=1;
tree[p].add=0;
}
}

void build(int p,int l,int r)
{
tree[p].l=l;
tree[p].r=r;
tree[p].add=0;
tree[p].status=0;
if(l==r)
return ;
int mid=(l+r)>>1;
build(p<<1,l,mid);
build(p<<1|1,mid+1,r);
}

void update(int p,int l,int r)
{
if(l == tree[p].l && tree[p].r == r)
{
tree[p].add^=1;
tree[p].status^=1;
return ;
}
pushdown(p);
int mid=(tree[p].l + tree[p].r)>>1;
if(r<=mid)
update(p<<1,l,r);
else if(l>mid)
update(p<<1|1,l,r);
else
{
update(p<<1,l,mid);
update(p<<1|1,mid+1,r);
}
}

int query(int p,int pos)
{
if(tree[p].l == tree[p].r && tree[p].l == pos )
return tree[p].status;
pushdown(p);
int mid=(tree[p].l + tree[p].r)>>1;
int s;
if(pos <= mid)
s=query(p<<1,pos);
else
s=query(p<<1|1,pos);
return s;
}

int main()
{
int n,m;
while(~scanf("%d%d",&n,&m))
{
build(1,1,n);
char op[3];
int x,y;
while(m--)
{
scanf("%s",op);
if(op[0]=='q')
{
scanf("%d",&x);
printf("%d\n",query(1,x));
}
else
{
scanf("%d%d",&x,&y);
update(1,x,y);
}
}
}
return 0;
}


你可能感兴趣的:(NOJ——[1438] Get Up, Soldier!)