POJ 2976 (二分)

Dropping tests
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8735   Accepted: 3043

Description

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be

.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains npositive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

Hint

To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).

Source

Stanford Local 2005

题意:n个数,知道每个数的收益和花费,扔掉其中的k个使得收益和/花费和最大.

需要从中选择n-k个.假设最终结果是x,二分枚举x,判断一种方案是否可行可以:

Σa[i]/Σb[i] = x    ----->    Σa[i]-x*Σb[i] = 0

因此可以对a[i]-x*b[i]从大到小排序选择前n-k个看是否满足>=0

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
#define maxn 1111
#define eps 1e-6

int n, k;
long long a[maxn], b[maxn];
double y[maxn];

bool ok (double x) {
    for (int i = 0; i < n; i++)
        y[i] = a[i]*1.0-x*b[i];
    sort (y, y+n);
    double ans = 0;
    for (int i = 0; i < k; i++) {
        ans += y[n-i-1];
    }
    return ans >= 0;
}

int main () {
    //freopen ("in.txt", "r", stdin);
    while (scanf ("%d%d", &n, &k) == 2) {
        if (!n && !k)
            break;
        for (int i = 0; i < n; i++)
            scanf ("%lld", &a[i]);
        for (int i = 0; i < n; i++)
            scanf ("%lld", &b[i]);
        k = n-k;
        double ans, l = 0, r = 1e15;
        while (r-l > eps) {
            double mid = (l+r)/2;
            if (ok (mid))
                l = mid;
            else
                r = mid;
        }
        if (ok (r))
            ans = r;
        else
            ans = l;
        ans *= 100;
        printf ("%lld\n", (long long)(ans+0.5));
    }
    return 0;
}


你可能感兴趣的:(POJ 2976 (二分))