【POJ】1258 - Agri-Net(克鲁斯塔尔)(水)

Agri-Net
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 47991   Accepted: 19879

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

Source

USACO 102


说实话,这道题题都懒得读,看了看数值大小看了看样例就直接写了,没想到真的这么水 = =

代码如下:

#include <cstdio>
#include <algorithm>
using namespace std;
int f[111];
struct node
{
	int st,end;
	int cost;
}road[5011];
int find(int x)
{
	if (x!=f[x])
		f[x]=find(f[x]);
	return f[x];
}
int join (int x,int y)
{
	int fx,fy;
	fx=find (x);
	fy=find (y);
	if (fx!=fy)
	{
		f[fx]=fy;
		return 1;
	}
	return 0;
}
bool cmp1(node a,node b)
{
	return a.cost<b.cost;
}
int main()
{
	int n;
	int ans;
	while (~scanf ("%d",&n))
	{
		ans=0;
		for (int i=1;i<=n;i++)
			f[i]=i;		//别忘了初始化 
		int num=-1;
		for (int i=1;i<=n;i++)
		{
			for (int j=1;j<=n;j++)
			{
				int tem;
				scanf ("%d",&tem);
				if (i<j)
				{
					num++;
					road[num].st=i;
					road[num].end=j;
					road[num].cost=tem;
				}
			}
		}
		sort (road,road+num+1,cmp1);
		int t=0;
		for (int i=0;i<=num;i++)
		{
			if (join(road[i].st,road[i].end))
			{
				ans+=road[i].cost;
				t++;
				if (t==n-1)
					break;
			}
		}
		printf ("%d\n",ans);
	}
	return 0;
}


你可能感兴趣的:(【POJ】1258 - Agri-Net(克鲁斯塔尔)(水))