【2016.3.22周练】D - Factorial (数论,二分法)(POJ-1401类型题)

D - D
Time Limit: 2000MS      Memory Limit: 32768KB      64bit IO Format: %lld & %llu
Submit  Status

Description

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero on the trail.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible



这道题和poj的1401题很相似,额外再用了二分法,和高中二分法求根式的差不多。

代码如下:

#include <cstdio>
#define MAX 0x7fffffff		//最大的 long int型数 
int cal(int n)		//计算n的阶乘后0的个数
{
	int ans = 0;
	while (n)
	{
		ans += n/5;
		n /= 5;
	}
	return ans;
}
int main()
{
	int u;
	int n;
	scanf ("%d",&u);
	int num = 1;
	while (u--)
	{
		scanf ("%d",&n);
		printf ("Case %d: ",num++);
		int left = 0,right = MAX;
		int mid;
		while (left <= right)
		{
			mid = (left + right)>>1;		//就是(left + right)/2的意思
			if (cal(mid) >= n)
				right = mid - 1;
			else
				left = mid +1;
		}
		if (cal(left) == n)		//若最后一次逼近的时候满足了条件,此时left==mid(无论left与right相差1还是相等) 
			printf ("%d\n",left);
		else
			printf ("impossible\n");
	}
	return 0;
}


你可能感兴趣的:(【2016.3.22周练】D - Factorial (数论,二分法)(POJ-1401类型题))