joj1968

 1968: Common Subsequence

Result TIME Limit MEMORY Limit Run Times AC Times JUDGE
1s 4096K 761 222 Standard

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0

Submit / Problem List / Status / Discuss








#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
char str1[500];
char str2[600];
int f[500][500];
int main()
{
    while(scanf("%s%s",str1+1,str2+1)==2)
    {
        int len1=strlen(str1+1);
        int len2=strlen(str2+1);
        for(int i=0;i<=len1;i++)f[i][0]=0;
        for(int i=0;i<=len2;i++)f[0][i]=0;
        for(int i=1;i<=len1;i++)
        {
            for(int j=1;j<=len2;j++)
            {
                if(str1[i]==str2[j])
                {
                    f[i][j]=f[i-1][j-1]+1;
                }
                else
                {
                    if(f[i-1][j]>f[i][j-1])
                    {
                        f[i][j]=f[i-1][j];
                    }
                    else
                    {
                        f[i][j]=f[i][j-1];
                    }
                }
            }
        }
        cout<<f[len1][len2]<<endl;
    }
    return 0;
}


这是一个字符串匹配的问题。f[i][j]代表第一个子串前i个字符与第二个子串前j个字符中最大的匹配长度。。


当str1[i]=str2[j]的时候f[i][j]=f[i-1][j-1]+1;否则f[i][j]=max(f[i-1][j],f[i][j-1])

你可能感兴趣的:(joj1968)