[sicily online]1198. Substring

/*
用sort默认排序的话,考虑ba和b
Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Dr lee cuts a string S into N pieces,s[1],…,s[N].   
Now, Dr lee gives you these N sub-strings: s[1],…s[N]. There might be several possibilities that the string S could be. For example, if Dr. lee gives you three sub-strings {“a”,“ab”,”ac”}, the string S could be “aabac”,”aacab”,”abaac”,…   
Your task is to output the lexicographically smallest S. 
Input

The first line of the input is a positive integer T. T is the number of the test cases followed.   
The first line of each test case is a positive integer N (1 <=N<= 8 ) which represents the number of sub-strings. After that, N lines followed. The i-th line is the i-th sub-string s[i]. Assume that the length of each sub-string is positive and less than 100. 
Output

The output of each test is the lexicographically smallest S. No redundant spaces are needed. 
Sample Input

1
3
a
ab
ac
Sample Output

aabac
*/

#include<iostream>
#include <iomanip>
#include<stdio.h>
#include<cmath>
#include<iomanip>
#include<list>
#include <map>
#include <vector>
#include <string>
#include <algorithm>
#include <sstream>
#include <stack>
#include<queue>
#include<string.h>
#include<set>
using namespace std;

bool cmp(const string &x1,const string &x2)//如果按照默认排序,考虑  ba,b
{
	return x1+x2<x2+x1;
}

int main()
{
	int T;
	cin>>T;
	for(int xx=0;xx<T;xx++)
	{
		int n;
		cin>>n;
		vector<string> data(n);
		for(int i=0;i<n;i++)
			cin>>data[i];
		sort(data.begin(),data.end(),cmp);
		for(int i=0;i<n;i++)
			cout<<data[i];
		cout<<endl;
	}
}

你可能感兴趣的:([sicily online]1198. Substring)