S-Nim
Time Limit: 2000MS |
|
Memory Limit: 65536K |
Total Submissions: 3735 |
|
Accepted: 1959 |
Description
Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:
- The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.
- The players take turns chosing a heap and removing a positive number of beads from it.
- The first player not able to make a move, loses.
Arthur and Caroll really enjoyed playing this simple game until they
recently learned an easy way to always be able to find the best move:
- Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).
- If the xor-sum is 0, too bad, you will lose.
- Otherwise, move such that the xor-sum becomes 0. This is always possible.
It is quite easy to convince oneself that this works. Consider these facts:
- The player that takes the last bead wins.
- After the winning player's last move the xor-sum will be 0.
- The xor-sum will change after every move.
Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win.
Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S = {2, 5} each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?
your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.
Input
Input consists of a number of test cases.
For each test case: The first line contains a number k (0 < k ≤ 100) describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps.
The last test case is followed by a 0 on a line of its own.
Output
For each position: If the described position is a winning position print a 'W'.If the described position is a losing position print an 'L'.
Print a newline after each test case.
Sample Input
2 2 5
3
2 5 12
3 2 4 7
4 2 3 7 12
5 1 2 3 4 5
3
2 5 12
3 2 4 7
4 2 3 7 12
0
Sample Output
LWW
WWL
Source
Svenskt Mästerskap i Programmering/Norgesmesterskapet 2004
题目大意:给定多组数据。每组数据的第一行给出取的要求,即一次可以取的个数。第一个数表示有几个,后面的表示可以取哪些数。接下来一行一个数表示询问的次数。接下来每行给出每个询问的石子信息,读入方式同上。
题解:这是一道十分典型的博弈问题。对于博弈问题,存在一个通解那就是SG函数。SG函数的原理与NIM游戏的证明相似。
最核心的三点
1.初始值SG[0]=0,SG值为零表示必败态
2.如果由这个状态只能转移到必胜态,那么他为必败态
3.如果一个状态能转移出一个必败态,那么他为必胜态
这便是SG函数的原理。其实SG函数就是暴力的求解出所有的必败态与必胜态,所有时间复杂度可能很高。c++中STL较慢,所有使用时要小心。
另外对于像nim游戏这样的多堆石子的问题,可以看成N个子问题求解。sg(1)^sg(2).....^sg(n)=0 则该状态为必败态(其中^表示异或)
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int f[120],num[120];
int sg[11000];
int n,k,m;
void sg1(int x)
{
memset(sg,0,sizeof(sg));
int hash[10020];
for (int i=1;i<=x;i++)
{
memset(hash,0,sizeof(hash));
for (int j=1;j<=m;j++)
if (i-f[j]>=0)
hash[sg[i-f[j]]]=1;
for (int j=0;;j++)
if (hash[j]==0)
{
sg[i]=j;
break;
}
}
}
int main()
{
scanf("%d",&m);
while (m!=0)
{
int maxn=0;
for (int i=1;i<=m;i++) scanf("%d",&f[i]);
scanf("%d",&n);
sg1(10000);
for (int i=1;i<=n;i++)
{
scanf("%d",&k);
for (int j=1;j<=k;j++) scanf("%d",&num[j]);
int l=0;
for (int j=1;j<=k;j++)
l^=sg[num[j]];
if (l==0)
printf("L");
else
printf("W");
}
printf("\n");
scanf("%d",&m);
}
}