poj 1094 Sorting It All Out(拓扑排序)

链接:

http://poj.org/problem?id=1094


题目

Sorting It All Out
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 21532   Accepted: 7403

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

分析:

这题典型的拓扑排序,但是有点变化。

题目样例的三种输出分别是:

1. 在第x个关系中可以唯一的确定排序,并输出。

2. 在第x个关系中发现了有回环(Inconsisitency矛盾)

3.全部关系都没有发现上面两种情况,输出第3种.


那么对于给定的m个关系,一个个的读进去,每读进去一次就要进行一次拓扑排序,如果发现情况1和情况2,那么就不用再考虑后面的那些关系了,但是还要继续读完后面的关系(但不处理)。如果读完了所有关系,还没有出现情况1和情况2,那么就输出情况3.

拓扑排序有两种方法,一种是算法导论上的,一种是用贪心的思想,这题用贪心的思想做更好。


贪心的做法:

1. 找到所有入度为0的点, 加入队列Q

2.取出队列Q的一个点,把以这个点为起点,所有它的终点的入度都减1. 如果这个过程中发现经过减1后入度变为0的,把这个点加入队列Q。

3.重复步骤2,直到Q为空。


这个过程中,如果同时有多个点的入度为0,说明不能唯一确定关系。

如果结束之后,所得到的经过排序的点少于点的总数,那么说明有回环。



题目还需要注意的一点:如果边(u,v)之前已经输入过了,那么之后这条边都不再加入。



代码:

#include<cstdio>
#include<cstring>
#include<vector>
#include<queue>
using namespace std;
const int N = 105;
int n,m,in[N],temp[N],Sort[N],t,pos, num;
char X, O, Y;
vector<int>G[N];
queue<int>q;

void init(){
    memset(in, 0, sizeof(in));
    for(int i=0; i<=n; ++i){
        G[i].clear();
    }
}

inline bool find(int u,int v){
    for(int i=0; i<G[u].size(); ++i)
        if(G[u][i]==v)return true;
    return false;
}

int topoSort(){
    while(!q.empty())q.pop();
    for(int i=0; i<n; ++i)if(in[i]==0){
            q.push(i);
    }
    pos=0;
    bool unSure=false;
    while(!q.empty()){
        if(q.size()>1) unSure=true;
        int t=q.front();
        q.pop();
        Sort[pos++]=t;
        for(int i=0; i<G[t].size(); ++i){
            if(--in[G[t][i]]==0)
                q.push(G[t][i]);
        }
    }
    if(pos<n) return 1;
    if(unSure)  return 2;
    return 3;
}

int main(){
    int x,y,i,flag,ok,stop;
    while(~scanf("%d%d%*c",&n,&m)){
        if(!n||!m)break;
        init();
        flag=2;
        ok=false;
        for(i=1; i<=m; ++i){
            scanf("%c%c%c%*c", &X,&O,&Y);
            if(ok) continue; // 如果已经判断了有回环或者可唯一排序,不处理但是要继续读
            x=X-'A', y=Y-'A';
            if(O=='<'&&!find(y,x)){
                    G[y].push_back(x);
                    ++in[x];
            }
            else if(O=='>'&&!find(x,y)){
                    G[x].push_back(y);
                    ++in[y];
            }
            // 拷贝一个副本,等下用来还原in数组
            memcpy(temp, in, sizeof(in)); 
            flag=topoSort();
            memcpy(in, temp, sizeof(temp));
            if(flag!=2){
                stop=i;
                ok=true;
            }
        }
        if(flag==3){
            printf("Sorted sequence determined after %d relations: ", stop);
            for(int i=pos-1; i>=0; --i)
                printf("%c",Sort[i]+'A');
            printf(".\n");
        }
        else if(flag==1){
            printf("Inconsistency found after %d relations.\n",stop);
        }
        else{
            printf("Sorted sequence cannot be determined.\n");
        }
    }
    return 0;
}

——  生命的意义,在于赋予它意义。

          
     原创 http://blog.csdn.net/shuangde800 , By   D_Double  (转载请标明)






你可能感兴趣的:(c,input,character,each,output,sorting)