HDU 2039 三角形(水~)

Description
给定三条边,请你判断一下能不能组成一个三角形
Input
输入数据第一行包含一个数M,接下有M行,每行一个实例,包含三个正数A,B,C,其中A,B,C <1000
Output
对于每个测试实例,如果三条边长A,B,C能组成三角形的话,输出YES,否则NO
Sample Input
2
1 2 3
2 2 2
Sample Output
NO
YES
Solution
水题
Code

#include<cstdio>
#include<iostream>
using namespace std;
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        double a,b,c;
        cin>>a>>b>>c;
        if(a+b>c&&a+c>b&&b+c>a)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

你可能感兴趣的:(HDU 2039 三角形(水~))