Problem Description
Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together.
His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.
Input
The first line of the input is a single positive integer T(0 < T <= 100).
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)
Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.
Sample Input
2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1
Sample Output
Case 1:
2 3 0
Case 2:
2 2 1
3 3 2
Author
输出的前两项是很简单的,第三项有点麻烦,我们要开一个数组记录每个点被转移的次数,然后在find的时候更新。
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int N=10010;
int father[N];
int rank[N];
int trans[N];
void init(int n)
{
memset(trans,0,sizeof(trans));
for(int i=1;i<=n;i++)
{
rank[i]=1;
father[i]=i;
}
}
int find(int x)
{
if(father[x]==x)
return x;
int temp=father[x];
father[x]=find(father[x]);
trans[x]+=trans[temp];
return father[x];
}
void merge(int x,int y)
{
int a=find(x);
int b=find(y);
if(a!=b)
{
trans[a]++;
rank[b]+=rank[a];
father[a]=b;
}
}
int main()
{
int T,n,q,x,y;
char op[3];
scanf("%d",&T);
int icase=1;
while(T--)
{
scanf("%d%d",&n,&q);
init(n);
printf("Case %d:\n",icase++);
for(int i=0;i<q;i++)
{
scanf("%s",op);
if(op[0]=='T')
{
scanf("%d%d",&x,&y);
merge(x,y);
}
else
{
scanf("%d",&x);
find(x);
printf("%d %d %d\n",father[x],rank[father[x]],trans[x]);
}
}
}
return 0;
}