DP:单调队列:Sliding Window

E - Sliding Window
Time Limit:12000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u
Submit Status

Description

An array of size n ≤ 10 6 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window position Minimum value Maximum value
[1  3  -1] -3  5  3  6  7  -1 3
 1 [3  -1  -3] 5  3  6  7  -3 3
 1  3 [-1  -3  5] 3  6  7  -3 5
 1  3  -1 [-3  5  3] 6  7  -3 5
 1  3  -1  -3 [5  3  6] 7  3 6
 1  3  -1  -3  5 [3  6  7] 3 7

Your task is to determine the maximum and minimum values in the sliding window at each position.

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7
#include <cstdio>
#include <cstdlib>

using namespace std;

const int MAXN = 1000010;
int a[MAXN], qup[MAXN], qdw[MAXN], ans[MAXN];
int hup, tup, hdw, tdw;
int n, len;

int main()
{
    scanf("%d%d", &n, &len);
    for (int i = 1; i <= n; i++)
        scanf("%d", &a[i]);;
    hup = 1; tup = 1; qup[1] = 1;
    hdw = 1; tdw = 1; qdw[1] = 1;//在qup(升序)的队首得窗中最小元素,在qdw(降序)的队首的窗中最大元素
    if (len == 1) printf("%d ", a[1]);
    ans[1] = a[1];
    for (int i = 2; i <= n; i++)//遍历每个元素
    {
        while (a[i] <= a[qup[tup]] && tup >= hup) tup--;//队不为空且队尾的元素比新元素小的时候才插入新元素
        qup[++tup] = i;//队尾加入新元素序号i

        while (a[i] >= a[qdw[tdw]] && tdw >= hdw) tdw--;//队不为空且队尾的元素比新元素大的时候才插入新元素    
        qdw[++tdw] = i;//队尾加入新元素序号i

        if (qup[hup] <= i - len) hup++;
        if (qdw[hdw] <= i - len) hdw++;//队首元素不在窗中的时候要做适当的调整
        if (i >= len) printf("%d ", a[qup[hup]]);//此时窗中的最小值
        ans[i] = a[qdw[hdw]];//此时窗中的最大值
    }
    printf("\n");
    for (int i = len; i <= n; i++)
        printf("%d ", ans[i]);
    printf("\n");
    return 0;
}


你可能感兴趣的:(IO,input,each,64bit,Numbers)