poj 2549 Sumsets

N - Sumsets
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit  Status  Practice  POJ 2549

Description

poj 2549 Sumsets_第1张图片Given S, a set of integers, find the largest d such that a + b + c = d where a, b, c, and d are distinct elements of S.

Input

Several S, each consisting of a line containing an integer 1 <= n <= 1000 indicating the number of elements in S, followed by the elements of S, one per line. Each element of S is a distinct integer between -536870912 and +536870911 inclusive. The last line of input contains 0.

Output

For each S, a single line containing d, or a single line containing "no solution".

Sample Input

5
2 
3 
5 
7 
12
5
2 
16 
64 
256 
1024
0

Sample Output

12
no solution

#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#define N 22222
#define INF -99999999
using namespace std;

int a[N];


int main()
{
    int n;
    while(scanf("%d",&n),n)
    {
        for(int i=0;i<n;i++)
        scanf("%d",&a[i]);

        sort(a,a+n);
        n--;
        int sum;
        int ans=INF;

        for(int i=n;i>=0;i--)
        {
            for(int j=n;j>=0;j--)
            {
                if(i==j)continue;
                sum=a[i]-a[j];

                for(int le=0,ri=j-1;le<ri;)//注意a和b 的枚举范围
                {

                    if(a[le]+a[ri]==sum)
                    {
                        ans=a[i];
                        break;
                    }
                    else if(a[ri]+a[le]>sum)
                    ri--;
                    else
                    le++;
                }

                if(ans!=INF)
                break;
            }
            if(ans!=INF)
            break;
        }

        if(ans==INF)
        printf("no solution\n");
        else
        printf("%d\n",ans);

    }

    return 0;
}






你可能感兴趣的:(poj 2549 Sumsets)