http://acm.hdu.edu.cn/showproblem.php?pid=2647
Problem Description
Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.
Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.
Output
For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.
Sample Input
Sample Output
一道拓扑排序的裸题,解题过程中要注意a比b拿的奖励要多,要用反向建图。这里容易出错别的直接套模板就哦了。
#include <string.h>
#include <stdio.h>
#include <iostream>
using namespace std;
struct note
{
int to;
int next;
};
note edge[20005];
int head[20005],ip,iq;
int indegree[20005],queue[20005],money[20005];
void add(int u,int v)
{
edge[ip].to=v,edge[ip].next=head[u],head[u]=ip++;
}
int main()
{
int m,n,a,b;
while(cin >>n>>m)
{
memset(head,-1,sizeof(head));
ip=iq=0;
memset(indegree,0,sizeof(indegree));
for(int i=0;i<=n;i++)
money[i]=888;
for(int i=0;i<m;i++)
{
cin>>a >>b;
add(b,a);
indegree[a]++;
}
for(int i=1;i<=n;i++)
if(indegree[i]==0)
queue[iq++]=i;
for(int i=0;i<iq;i++)
{
for(int k=head[queue[i]];k!=-1;k=edge[k].next)
{
if(--indegree[edge[k].to]==0)
{
money[edge[k].to]=money[queue[i]]+1;
queue[iq++]=edge[k].to;
}
}
}
int sum=0;
if(iq ==n)
{
for(int i=1;i<=n;i++)
{
sum+=money[i];
}
printf("%d\n",sum);
}
else
printf("-1\n");
}
return 0;
}