ZOJ 3323(B)模拟

Somali Pirates Time Limit: 1 Second       Memory Limit: 32768 KB

It is said that the famous Somali Pirates hate digits. So their QQ passwords never contain any digit. Given some lines of candidate passwords, you are asked to delete all the digits in the passwords and print other characters in their original order. So the Somali Pirates can use them as their QQ passwords^^

Input

There are multiple test cases. The first line of input is an integer T (T <= 10) indicating the number of test cases.

Each case contains a line indicating a candidate password. The length of the password is between 1 and 20, inclusive. Besides, the password consists of only digits and English letters.

Output

For each candidate password, delete all the digits and print the remaining characters in a line.

Sample Input

2
BeatLA123
1plus1equals1

Sample Output

BeatLA
plusequals



题意:输出字母

题解:直接扫一遍输出


#include<cstdio>  
#include<cstring>  
#include<cstdlib>  
#include<cmath>  
#include<iostream>  
#include<algorithm>  
#include<vector>  
#include<map>  
#include<set>  
#include<queue>  
#include<string>  
#include<bitset>  
#include<utility>  
#include<functional>  
#include<iomanip>  
#include<sstream>  
#include<ctime>  
using namespace std;

#define N int(1e5)  
#define inf int(0x3f3f3f3f)  
#define mod int(1e9+7)  
typedef long long LL;


#ifdef CDZSC  
#define debug(...) fprintf(stderr, __VA_ARGS__)  
#else  
#define debug(...)   
#endif  

int main()
{
#ifdef CDZSC  
	freopen("i.txt", "r", stdin);
	//freopen("o.txt","w",stdout);  
	int _time_jc = clock();
#endif  
	char s[100];
	int t;
	scanf("%d", &t);
	while (t--)
	{
		scanf("%s", s);
		for (int i = 0; s[i]; i++)
		{
			if (!(s[i] >= '0'&&s[i] <= '9'))
				putchar(s[i]);
		}
		putchar('\n');
	}
#ifdef CDZSC  
	debug("time: %d\n", int(clock() - _time_jc));
#endif  
	return 0;
}







你可能感兴趣的:(ZOJ 3323(B)模拟)