【Lightoj】1116 - 分解因数(水)

Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu
Submit Status Practice LightOJ 1116

Description

Ekka and his friend Dokka decided to buy a cake. They both love cakes and that's why they want to share the cake after buying it. As the name suggested that Ekka is very fond of odd numbers and Dokka is very fond of even numbers, they want to divide the cake such that Ekka gets a share of N square centimeters and Dokka gets a share of M square centimeters where N is odd and M is even. Both N and M are positive integers.

They want to divide the cake such that N * M = W, where W is the dashing factor set by them. Now you know their dashing factor, you have to find whether they can buy the desired cake or not.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer W (2 ≤ W < 263). And W will not be a power of 2.

Output

For each case, print the case number first. After that print "Impossible" if they can't buy their desired cake. If they can buy such a cake, you have to print N and M. If there are multiple solutions, then print the result where M is as small as possible.

Sample Input

3

10

5

12

Sample Output

Case 1: 5 2

Case 2: Impossible

Case 3: 3 4



也挺考验思维的。

代码如下(说明很清楚):

#include <stdio.h>
int main()
{
	int u;
	long int sum;
	long int n,m;
	long int t;
	scanf ("%d",&u);
	for (int p=1;p<=u;p++)
	{
		scanf ("%ld",&sum);		 
		printf ("Case %d: ",p);
		t=sum;
		if (sum&1)		//任何奇数都没有偶数的因子 
		{
			printf ("Impossible\n");
		}
		else
		{
			while (!(sum&1))		//依次分解出2的因子,剩下的奇数即为最大奇数因子 
			{
				sum=sum/2;
			}
			n=sum;
			m=t/sum;
			printf ("%ld %ld\n",n,m);
		}
	}
	return 0;
}


你可能感兴趣的:(【Lightoj】1116 - 分解因数(水))