hihocoder-#1082 : 然而沼跃鱼早就看穿了一切

#1082 : 然而沼跃鱼早就看穿了一切

时间限制: 1000ms
单点时限: 1000ms
内存限制: 256MB

描述

hihocoder-#1082 : 然而沼跃鱼早就看穿了一切_第1张图片

fjxmlhx每天都在被沼跃鱼刷屏,因此他急切的找到了你希望你写一个程序屏蔽所有句子中的沼跃鱼(“marshtomp”,不区分大小写)。为了使句子不缺少成分,统一换成 “fjxmlhx” 。

输入

输入包括多行。

每行是一个字符串,长度不超过200。

一行的末尾与下一行的开头没有关系。

输出

输出包含多行,为输入按照描述中变换的结果。

样例输入
The Marshtomp has seen it all before.
marshTomp is beaten by fjxmlhx!
AmarshtompB
样例输出
The fjxmlhx has seen it all before.
fjxmlhx is beaten by fjxmlhx!
AfjxmlhxB
      
      
      
      
解答:
using System;
class ClassA
{
    static void Main()
    {
        string s,result;
        while((s=result=Console.ReadLine())!=null)
        {
            for(int i=0;i<s.Length-8;i++)
            {
                if(s[i]=='M'||s[i]=='m')
                    if(s[i+1]=='A'||s[i+1]=='a')
                        if(s[i+2]=='R'||s[i+2]=='r')
                            if(s[i+3]=='S'||s[i+3]=='s')
                                if(s[i+4]=='H'||s[i+4]=='h')
                                    if(s[i+5]=='T'||s[i+5]=='t')
                                        if(s[i+6]=='O'||s[i+6]=='o')
                                            if(s[i+7]=='M'||s[i+7]=='m')
                                                if(s[i+8]=='P'||s[i+8]=='p')
                                                {
                                                   result = result.Replace(s.Substring(i, 9), "fjxmlhx");
                                                   i += 8;
                                                }
            }
            Console.WriteLine(result);
        }
    }
}


你可能感兴趣的:(算法,字符串)