【杭电oj】2387 - Til the Cows Come Home(dijkstra)

Til the Cows Come Home
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 40239   Accepted: 13677

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.

Source

USACO 2004 November


最短路的最基础的题了,并不难。但是要注意重复路径和 m、n 表示的内容。

代码如下:

#include <cstdio>
#include <cstring>
#define MAX 666666		//这个数还要定义的大一点 
int n,m;
int map[1011][1011];
int used[1011];
int dis[1011];
int min(int a,int b)
{
	if (a > b)
		return b;
	return a;
}
void init()
{
	for (int i = 1 ; i <= n ; i++)
	{
		used[i] = 0;
		dis[i] = MAX;
		for (int j = 1 ; j <= n ; j++)
			map[i][j] = map[j][i] = MAX;
	}
}
void dij()
{
	int v;
	dis[1] = 0;
	while (1)
	{
		v = -1;
		for (int u = 1 ; u <= n ; u++)
		{
			if (!used[u] && (v == -1 || dis[u] < dis[v]))
				v = u;
		}
		if (v == -1)
			break;
		used[v] = 1;
		for (int i = 1 ; i <= n ; i++)
		{
			if (dis[i] > dis[v] + map[v][i])
				dis[i] = dis[v] + map[v][i];
		}
	}
}
int main()
{
	scanf ("%d %d",&m,&n);
	init();
	while (m--)
	{
		int t1,t2,t3;
		scanf ("%d %d %d",&t1,&t2,&t3);
		map[t1][t2] = map[t2][t1] = min(map[t1][t2],t3);
	}
	dij();
	printf ("%d\n",dis[n]);
	return 0;
}


你可能感兴趣的:(【杭电oj】2387 - Til the Cows Come Home(dijkstra))