FZU 2111Min Number

题目链接:http://vjudge.net/problem/viewProblem.action?id=35185

Description

Now you are given one non-negative integer n in 10-base notation, it will only contain digits ('0'-'9'). You are allowed to choose 2 integers i and j, such that: i!=j, 1≤i<j≤|n|, here |n| means the length of n’s 10-base notation. Then we can swap n[i] and n[j].

For example, n=9012, we choose i=1, j=3, then we swap n[1] and n[3], then we get 1092, which is smaller than the original n.

Now you are allowed to operate at most M times, so what is the smallest number you can get after the operation(s)?

Please note that in this problem, leading zero is not allowed!

Input

The first line of the input contains an integer T (T≤100), indicating the number of test cases.

Then T cases, for any case, only 2 integers n and M (0≤n<10^1000, 0≤M≤100) in a single line.

Output

For each test case, output the minimum number we can get after no more than M operations.

Sample Input

3
9012 0
9012 1
9012 2

Sample Output

9012
1092
1029
题目的意思差不多就是把前m小的元素放到串的前面 当然0不能放到第一位
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
using namespace std;
char  a[1010];
int main()
{
    int n,m;
    cin>>n;
    while(n--){
        cin>>a>>m;
        int len=strlen(a);
        int t=0,i,j;
        int jlu;
        char c;
        for( i=0;i<len&&m>0;i++){
            c=a[i];
            jlu=i;
            if(a[i]=='1'&&i==0)
                continue;
            if(i==0){
            for(j=i+1;j<len;j++){
                    if(c>=a[j]&&a[j]!=a[i]&&a[j]!='0'){
                        jlu=j;
                        c=a[j];
                    }
            }
                if(a[jlu]!=a[i]){
                    c=a[i];
                    a[i]=a[jlu];
                    a[jlu]=c;
                    m--;
                }
            }
            else{
                for(j=i+1;j<len;j++){
                    if(c>=a[j]&&a[j]!=a[i]){
                        jlu=j;
                        c=a[j];
                    }
                }
                if(c!=a[i]){
                    c=a[i];
                    a[i]=a[jlu];
                    a[jlu]=c;
                    m--;
                }
            }
           // cout<<"i "<<i<<endl;
        }
        puts(a);
    }
    return 0;
}


你可能感兴趣的:(FZU 2111Min Number)