poj 3278 Catch That Cow

                                               Catch That Cow

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 60418   Accepted: 18842

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a pointN (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 orX + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

#include <iostream>
#include <cstring>
#include <queue>
#include <cstdio>

using namespace std;
struct node
{
    int step;
    int num;
} b,c;
int n,k;
bool vis[100001*2];

int BFS()
{
    memset(vis,false,sizeof(vis));
    b.step = n;
    b.num = 0;
    vis[n] = true;
    queue<node >q;
    q.push(b);
    while(!q.empty())
    {
        b = q.front();
        q.pop();
        if(b.step == k)
            return b.num;
        if(b.step + 1 <= k && !vis[b.step+1])
        {

            c.step = b.step+1;
            c.num = b.num+1;
            vis[c.step] = true;
            q.push(c);
        }
        if(b.step - 1 >= 0 && !vis[b.step-1])
        {

            c.step = b.step-1;
            c.num = b.num+1;
            vis[c.step] = true;
            q.push(c);
        }
        if(b.step <<1  <= k<<1 && !vis[b.step<<1])
        {

            c.step = b.step<<1;
            c.num = b.num+1;
            vis[c.step] = true;
            q.push(c);
        }
    }
}

int main()
{
    while(cin>>n>>k)
        cout<<BFS()<<endl;
    return 0;
}


你可能感兴趣的:(poj 3278 Catch That Cow)