还是畅通工程(并查集+最小生成树)

Link:http://acm.hdu.edu.cn/showproblem.php?pid=1233

Problem:

还是畅通工程

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26816    Accepted Submission(s): 11967


Problem Description
某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。
 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。
 

Output
对每个测试用例,在1行里输出最小的公路总长度。
 

Sample Input
   
   
   
   
3 1 2 1 1 3 2 2 3 4 4 1 2 1 1 3 4 1 4 1 2 3 3 2 4 2 3 4 5 0
 

Sample Output
   
   
   
   
3 5
Hint
Hint
Huge input, scanf is recommended.
 

Source
浙大计算机研究生复试上机考试-2006年
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1875  1879  1863  1874  1325 
 


My code:

#include<iostream>
#include<algorithm>
using namespace std;
int n,pre[111],ans;
struct edge{
int u;
int v;
int w;
}e[5000];
bool cmp(edge a,edge b)
{
return a.w<b.w;
}
void init()
{
for(int i=1;i<=n;i++)
pre[i]=i;
}
int fin(int root)
{
int son,tmp;
son=root;
while(root!=pre[root])
{
root=pre[root];
}
while(root!=son)
{
tmp=pre[son];
pre[son]=root;
son=tmp;
}
return root;
}
bool join(int root1,int root2)
{
int x,y;
x=fin(root1);
y=fin(root2);
if(x!=y)
{
pre[x]=y;
return true;
}
return false;
}
void kcluscal(int n,int m)
{
sort(e+1,e+m+1,cmp);
ans=0;
for(int i=1;i<=m;i++)
{
if(join(e[i].u,e[i].v))
ans+=e[i].w;
}
}
int main()
{
int i,m;
while(scanf("%d",&n)==1&&n)
{
m=0;
for(i=1;i<=n*(n-1)/2;i++)
{
m++;
scanf("%d%d%d",&e[m].u,&e[m].v,&e[m].w);
}
init();
kcluscal(n,m);
printf("%d\n",ans);
}
return 0;
}

你可能感兴趣的:(数据结构,算法,ACM,并查集)