HDU 2029 Palindromes _easy version(水~)

Description
“回文串”是一个正读和反读都一样的字符串,比如“level”或者“noon”等等就是回文串。请写一个程序判断读入的字符串是否是“回文”
Input
输入包含多个测试实例,输入数据的第一行是一个正整数n,表示测试实例的个数,后面紧跟着是n个字符串
Output
如果一个字符串是回文串,则输出”yes”,否则输出”no”
Sample Input
4
level
abcde
noon
haha
Sample Output
yes
no
yes
no
Solution
水题
Code

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        char s[1111];
        scanf("%s",s);
        int len=strlen(s),i,j;
        for(i=0,j=len-1;i<j;i++,j--)    
            if(s[i]!=s[j])
            {
                printf("no\n");
                break;
            }
        if(i>=j)
            printf("yes\n");
    }
    return 0;
}

你可能感兴趣的:(HDU 2029 Palindromes _easy version(水~))