poj 1751 Highways (最小生成树+记录路径)

Highways
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 7187   Accepted: 1961   Special Judge

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length. 

Input

The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built. 

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of i th town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location. 

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway. 

Output

Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space. 

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty. 

Sample Input

9
1 5
0 0 
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2

Sample Output

1 6
3 7
4 9
5 7
8 3

Source

Northeastern Europe 1999

题意:不说了。
思路:由于点少边多  适合用Prim 算法   
感想:题目还是满水的,就是还坑了我一下,我天真的用memset将double型数组赋值为INF。汗。。。
代码:
#include <cstdio>
#include <cstring>
#include <cmath>
#define maxn 800
using namespace std;

const int INF=0x3f3f3f3f;
int n,m,ans,cnt;
bool vis[maxn];
int u[maxn],v[maxn];
int x[maxn],y[maxn];
int pre[maxn];
double dist[maxn],city[maxn][maxn];

void init()
{
    int i,j;
    for(i=1;i<=n;i++)
    {
        dist[i]=INF;
        for(j=i+1;j<=n;j++)
        {
            city[i][j]=city[j][i]=INF;
        }
    }
    memset(vis,0,sizeof(vis));
    memset(pre,0,sizeof(pre));
}
void disjk()
{
    int i,j,ii,k,now=1;
    double mi;
    cnt=0;
    vis[1]=1;
    for(i=1; i<n; i++)
    {
        for(j=1; j<=n; j++)
        {
            if(!vis[j]&&city[now][j]<dist[j])
            {
                dist[j]=city[now][j];
                pre[j]=now;
            }
        }
        mi=INF;
        k=0;
        for(j=1; j<=n; j++)
        {
            if(!vis[j]&&dist[j]<mi)
            {
                mi=dist[j];
                k=j;
            }
        }
        if(city[pre[k]][k]) // 如果边不是原来就建好的就将边加入答案数组
        {
            cnt++;
            u[cnt]=pre[k];
            v[cnt]=k;
        }
        now=k;
        vis[k]=1;
    }
}
double caldist(int k1,int k2)    // 计算两点间的距离
{
    double x1,y1;
    x1=x[k1]-x[k2];
    y1=y[k1]-y[k2];
    return sqrt(x1*x1+y1*y1);
}
void solve()
{
    int i,j;
    for(i=1; i<=n; i++)
    {
        for(j=i+1; j<=n; j++)
        {
            if(!city[i][j]) continue ;
            city[i][j]=city[j][i]=caldist(i,j);
        }
    }
}
int main()
{
    int i,j,t=-1,l,r;
    while(~scanf("%d",&n))
    {
        t++;
        init();
        for(i=1; i<=n; i++)
        {
            scanf("%d%d",&x[i],&y[i]);
        }
        scanf("%d",&m);
        for(i=1; i<=m; i++)
        {
            scanf("%d%d",&l,&r);
            city[l][r]=city[r][l]=0;
        }
        solve();
        disjk();
        if(t) printf("\n");
        for(i=1; i<=cnt; i++)
        {
            printf("%d %d\n",u[i],v[i]);
        }
    }
    return 0;
}




你可能感兴趣的:(poj 1751 Highways (最小生成树+记录路径))