【CodeForces】606A - Magic Spheres(水)

Magic Spheres
Crawling in process... Crawling failed
Time Limit: 2000 MS     Memory Limit: 262144 KB     64bit IO Format: %I64d & %I64u
Submit Status Practice CodeForces 606A

Description

Carl is a beginner magician. He has a blue, b violet and c orange magic spheres. In one move he can transform two spheres of the same color into one sphere of any other color. To make a spell that has never been seen before, he needs at least x blue, y violet and z orange spheres. Can he get them (possible, in multiple actions)?

Input

The first line of the input contains three integers a, b and c (0 ≤ a, b, c ≤ 1 000 000) — the number of blue, violet and orange spheres that are in the magician's disposal.

The second line of the input contains three integers, x, y and z (0 ≤ x, y, z ≤ 1 000 000) — the number of blue, violet and orange spheres that he needs to get.

Output

If the wizard is able to obtain the required numbers of spheres, print "Yes". Otherwise, print "No".

Sample Input

Input
4 4 0
2 1 2
Output
Yes
Input
5 6 1
2 7 2
Output
No
Input
3 3 3
2 2 2
Output
Yes

Sample Output

Hint

In the first sample the wizard has 4 blue and 4 violet spheres. In his first action he can turn two blue spheres into one violet one. After that he will have 2 blue and 5 violet spheres. Then he turns 4 violet spheres into 2 orange spheres and he ends up with 2 blue, 1 violet and 2 orange spheres, which is exactly what he needs.



该死的提示,看过以后我还以为是变换过后要正好等于给出的三个数值的。耽误了好久。也怪自己没仔细看题吧。

代码如下(这个代码有很大的优化余地,当时为了比赛赶正确率,用最朴素的方法):

#include <stdio.h>
int main()
{
	int a1,a2,a3;
	int t1,t2,t3;
	int c1,c2,c3;
	int jdg;
	while (~scanf ("%d%d%d",&a1,&a2,&a3))
	{
		scanf ("%d%d%d",&t1,&t2,&t3);
		c1=a1-t1;
		c2=a2-t2;
		c3=a3-t3;
		if (c1>=0 && c2>=0 && c3>=0)
		{
			printf ("Yes\n");
		}
		else
		{
			if (c1>0)
				c1/=2;
			if (c2>0)
				c2/=2;
			if (c3>0)
				c3/=2;
			jdg=c1+c2+c3;
			if (jdg>=0)
			{
				printf ("Yes\n");
			}
			else
			{
				printf ("No\n");
			}
		}
	}
	return 0;
}



你可能感兴趣的:(【CodeForces】606A - Magic Spheres(水))