hdoj 4268 Alice and Bob 【贪心 + set】

题目链接:hdoj 4268 Alice and Bob

Alice and Bob

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4156 Accepted Submission(s): 1301

Problem Description
Alice and Bob’s game never ends. Today, they introduce a new game. In this game, both of them have N different rectangular cards respectively. Alice wants to use his cards to cover Bob’s. The card A can cover the card B if the height of A is not smaller than B and the width of A is not smaller than B. As the best programmer, you are asked to compute the maximal number of Bob’s cards that Alice can cover.
Please pay attention that each card can be used only once and the cards cannot be rotated.

Input
The first line of the input is a number T (T <= 40) which means the number of test cases.
For each case, the first line is a number N which means the number of cards that Alice and Bob have respectively. Each of the following N (N <= 100,000) lines contains two integers h (h <= 1,000,000,000) and w (w <= 1,000,000,000) which means the height and width of Alice’s card, then the following N lines means that of Bob’s.

Output
For each test case, output an answer using one line which contains just one number.

Sample Input
2
2
1 2
3 4
2 3
4 5
3
2 3
5 7
6 8
4 1
2 5
3 4

Sample Output
1
2

题意:A有n个矩形,B有n个矩形。问你A有多少个矩形可以覆盖B的一个矩形,一个矩形只能被覆盖一次。

思路:贪心,显然每次覆盖选择尽量靠近A矩形大小的B矩形。我们可以sort下所有的A、B矩形,然后在A矩形长的限制下插入合法的B矩形,下面就是查询插入的B矩形中最靠近A矩形宽的矩形。为了方便查询,插入的B矩形按宽升序排列最方便,那就用set了。

AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <map>
#include <set>
#include <queue>
#define CLR(a, b) memset(a, (b), sizeof(a))
#define fi first
#define se second
using namespace std;
typedef long long LL;
typedef pair<int, int> pii;
const int MAXN = 1e5 + 10;
const int MOD = 1e9 + 7;
const int INF = 0x3f3f3f3f;
pii a[MAXN], b[MAXN];
multiset<int> B;
multiset<int> :: iterator it;
int main()
{
    int t; scanf("%d", &t);
    while(t--) {
        int n; scanf("%d", &n);
        for(int i = 1; i <= n; i++) {
            scanf("%d%d", &b[i].fi, &b[i].se);
        }
        for(int i = 1; i <= n; i++) {
            scanf("%d%d", &a[i].fi, &a[i].se);
        }
        sort(a+1, a+n+1); sort(b+1, b+n+1);
        int j = 1; B.clear(); int ans = 0;
        for(int i = 1; i <= n; i++) {
            while(j <= n && a[j].fi <= b[i].fi) {
                B.insert(a[j].se); j++;
            }
            if(B.size() == 0) continue;
            it = B.upper_bound(b[i].se);
            if(it != B.begin()) {
                it--; ans++;
                B.erase(it);
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}

你可能感兴趣的:(hdoj 4268 Alice and Bob 【贪心 + set】)