joj1018

 1018: Anagrams by Stack

Result TIME Limit MEMORY Limit Run Times AC Times JUDGE
5s 8192K 1175 519 Standard

How can anagrams result from sequences of stack operations? There are two sequences of stack operators which can convert TROT to TORT:

[
i i i i o o o o
i o i i o o i o
]

where i stands for Push and o stands for Pop. Your program should, given pairs of words produce sequences of stack operations which convert the first word to the second.

Input

The input will consist of several lines of input. The first line of each pair of input lines is to be considered as a source word (which does not include the end-of-line character). The second line (again, not including the end-of-line character) of each pair is a target word. Both the two words have no more than 10 characters. The end of input is marked by end of file.

Output

For each input pair, your program should produce a sorted list of valid sequences of i and owhich produce the target word from the source word. Each list should be delimited by

[
]
and the sequences should be printed in "dictionary order". Within each sequence, each  i and  ois followed by a single space and each sequence is terminated by a new line.

Process

A stack is a data storage and retrieval structure permitting two operations:

Push - to insert an item and
Pop - to retrieve the most recently pushed item

We will use the symbol i (in) for push and o (out) for pop operations for an initially empty stack of characters. Given an input word, some sequences of push and pop operations are valid in that every character of the word is both pushed and popped, and furthermore, no attempt is ever made to pop the empty stack. For example, if the word FOO is input, then the sequence:

i i o i o o is valid, but
i i o is not (it's too short), neither is
i i o o o i (there's an illegal pop of an empty stack)

Valid sequences yield rearrangements of the letters in an input word. For example, the input word FOO and the sequence i i o i o o produce the anagram OOF. So also would the sequencei i i o o o. You are to write a program to input pairs of words and output all the valid sequences of i and o which will produce the second member of each pair from the first.

Sample Input

madam
adamm
bahama
bahama
long
short
eric
rice

Sample Output

[
i i i i o o o i o o 
i i i i o o o o i o 
i i o i o i o i o o 
i i o i o i o o i o 
]
[
i o i i i o o i i o o o 
i o i i i o o o i o i o 
i o i o i o i i i o o o 
i o i o i o i o i o i o 
]
[
]
[
i i o i o i o o 
]






/*这是一个深度优先搜索的题,通过这个题我有对深度优先搜索有了更深刻的理解。。
一开始做这道题目的时候老是出错后来我发现了是因为自己在执行‘i’的时候
没有进行回溯。因此一定要记住在深度优先搜索当中面对多种情况时候一定要记着回溯!!
!!!!*/


#include<cstdio>
#include<iostream>
#include<stack>
#include<string.h>
using namespace std;
char source[11];
char destination[11];
char out[25];
char temp[11];
stack<char>s;
void dfs(int so,int de,int ot)
{
if(ot==2*strlen(source))
{
out[ot]='\0';
temp[de]='\0';
if(!strcmp(destination,temp))
{
for(int i=0;out[i]!='\0';i++)
{
   putchar(out[i]);
   putchar(' ');
}
printf("\n");
}
}
else
{
if(source[so]!='\0')
{
stack<char>ss=s;
out[ot]='i';
s.push(source[so]);
dfs(so+1,de,ot+1);
s=ss;//回溯
}
if(!s.empty())
{
out[ot]='o';
temp[de]=s.top();
s.pop();
dfs(so,de+1,ot+1);
}
}
}
int main()
{
freopen("in.txt","r",stdin);
freopen("out.txt","w",stdout);
while(gets(source),gets(destination))
{
printf("[\n");
while(!s.empty())
s.pop();
dfs(0,0,0);
printf("]\n");
}
return 0;
}



你可能感兴趣的:(joj1018)