HDU 1004:Let the Balloon Rise【STl】

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 99685    Accepted Submission(s): 38198


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
   
   
   
   
5 green red blue red red 3 pink orange pink 0
 

Sample Output
   
   
   
   
red pink
 
AC-code:
#include<iostream>
#include<cstdio>
#include<algorithm>//map所需的头文件 
#include<cstring>
#include<map>
using namespace std;
map<string,int>mp;//定义map类型的下标为字符串,值为整数mp容器 
int main()
{
	int n,i,num;
	char ans[20],str[20];
	while(scanf("%d",&n),n)
	{
		num=0;
		for(i=0;i<n;i++)
		{
			scanf("%s",str);
			if(mp.find(str)==mp.end())//判断以str为下标的mp的值是否为空 
				mp[str]=1;
			else
				mp[str]++;
			if(mp[str]>num)//记录mp值最大的下标及其mp值 
			{
				num=mp[str];
				strcpy(ans,str);
			 } 
		}
		printf("%s\n",ans);
	}
	return 0;
}


你可能感兴趣的:(HDU 1004:Let the Balloon Rise【STl】)