【杭电oj】1108 - 最小公倍数(gcd,水)

最小公倍数

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 44749    Accepted Submission(s): 24922


Problem Description
给定两个正整数,计算这两个数的最小公倍数。
 

Input
输入包含多组测试数据,每组只有一行,包括两个不大于1000的正整数.
 

Output
对于每个测试用例,给出这两个数的最小公倍数,每个实例输出一行。
 

Sample Input
   
   
   
   
10 14
 

Sample Output
   
   
   
   
70
 

Source
POJ  


此题难度不大,主要是对gcd的学习。

代码如下:

#include <stdio.h>
int gcd(int a,int b)
{
	if (!(a%b))
		return b;
	int t;
	t=b;
	b=a%b;
	gcd(t,b);
}
int main()
{
	int a,b;
	int g;
	int ans;
	while (~scanf ("%d %d",&a,&b))
	{
		g=gcd(a,b);
		ans=a/g*b;
		printf ("%d\n",ans);
	}
	return 0;
}




你可能感兴趣的:(【杭电oj】1108 - 最小公倍数(gcd,水))