hdu2266(DFS)

How Many Equations Can You Find

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 487    Accepted Submission(s): 306


Problem Description
Now give you an string which only contains 0, 1 ,2 ,3 ,4 ,5 ,6 ,7 ,8 ,9.You are asked to add the sign ‘+’ or ’-’ between the characters. Just like give you a string “12345”, you can work out a string “123+4-5”. Now give you an integer N, please tell me how many ways can you find to make the result of the string equal to N .You can only choose at most one sign between two adjacent characters.
 

Input
Each case contains a string s and a number N . You may be sure the length of the string will not exceed 12 and the absolute value of N will not exceed 999999999999.
 

Output
The output contains one line for each data set : the number of ways you can find to make the equation.
 

Sample Input
   
   
   
   
123456789 3 21 1
 

Sample Output
   
   
   
   
18 1
 

Author
dandelion
 

Source
HDU 8th Programming Contest Online
 

Recommend
lcy
 
本题要求在原字符串中添加一些+、-号,使所得的值所给定值相同。
这提示到很明显的搜索题。注意搜索的方法。
 
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

char str[20];
__int64 n,ans;
int len;


void dfs(__int64 sum,int id)
{
	int i;
	if(id==len)
	{
		if(sum==n)
			ans++;
		return ;
	}
	__int64 tmp=0;
	for(i=id;i<len;i++)
	{
		tmp=tmp*10+str[i]-'0';
		dfs(sum+tmp,i+1);
		if(id!=0)
			dfs(sum-tmp,i+1);
	}
}

int main()
{
	while(~scanf("%s%I64d",str,&n))
	{
		ans=0;
		len=strlen(str);
		dfs(0,0);
		printf("%I64d\n",ans);
	}
	return 0;
}

你可能感兴趣的:(搜索)