HDU5347 多校赛1005 MZL's chemistry

哈哈,还得靠惊人的记忆力啊

Problem Description
   
   
   
   
MZL define F(X) as the first ionization energy of the chemical element X Now he get two chemical elements U,V ,given as their atomic number,he wants to compare F(U) and F(V) It is guaranteed that atomic numbers belongs to the given set: {1,2,3,4,..18,35,36,53,54,85,86} It is guaranteed the two atomic numbers is either in the same period or in the same group It is guaranteed that xy
 

Input
   
   
   
   
There are several test cases For each test case,there are two numbers u,v ,means the atomic numbers of the two element
 

Output
   
   
   
   
For each test case,if F(u)>F(v) ,print "FIRST BIGGER",else print"SECOND BIGGER"
 

Sample Input
   
   
   
   
1 2 5 3
 

Sample Output
   
   
   
   
SECOND BIGGER FIRST BIGGER


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>

using namespace std;


int main()
{
    double F[] = {0,13.598,24.587,5.391,9.322,8.298,11.261,14.534,13.618,17.422,21.564,5.139,7.646,5.985,8.151,10.486,10.361,12.967,15.759,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,11.813,13.999,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,10.451,12.129,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,10,10.748};
    int u,v;
    while(~scanf("%d%d",&u,&v))
    {
        if(F[u]<F[v])
            printf("SECOND BIGGER\n");
        else
            printf("FIRST BIGGER\n");
    }
    return 0;
}


你可能感兴趣的:(HDU5347 多校赛1005 MZL's chemistry)