POJ 3041 Asteroids(最小点覆盖)

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.  

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space.  
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS:  
The following diagram represents the data, where "X" is an asteroid and "." is empty space:  
X.X  
.X.  
.X.  

OUTPUT DETAILS:  
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

给一个N*N的矩阵,有些格子有障碍,要求我们消除这些障碍,问每次消除一行或一列的障碍,最少要几次。这里将每行x看成一个X结点,每列Y看成一个Y结点,障碍的坐标x,y看成X到Y的一条边,构建出图后,就变成了找最少的点,使得这些点与所有的边相邻,即最小点覆盖问题。


#include <iostream>
#include <string.h>
using namespace std;
int grid[510][510],used[510],link[510];
int N;
int dfs(int x)
{
 for(int i=1;i<=N;i++)
 {
  if(!used[i]&&grid[x][i])
  {
   used[i]=1;
   if(link[i]==-1||dfs(link[i]))
   {
    link[i]=x;
    return 1;
   }
  }
 }
 return 0;
}
int main()
{
 int R,C,K,sum,i;
 cin>>N>>K;
    memset(grid,0,sizeof(grid));
    memset(link,-1,sizeof(link));
    sum=0;
    for(i=1;i<=K;i++)
    {
        cin>>R>>C;
        grid[R][C]=1;
    }
    for(i=1;i<=N;i++)
    {
        memset(used,0,sizeof(used));
        if(dfs(i))
            sum++;
    }
    cout<<sum<<endl;
 return 0;
}

你可能感兴趣的:(POJ 3041 Asteroids(最小点覆盖))