hdoj 5443 The Water Problem 【RMQ】



The Water Problem

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 343    Accepted Submission(s): 281


Problem Description
In Land waterless, water is a very limited resource. People always fight for the biggest source of water. Given a sequence of water sources with  a1,a2,a3,...,an representing the size of the water source. Given a set of queries each containing  2  integers  l  and  r , please find out the biggest water source between  al  and  ar .
 

Input
First you are given an integer  T(T10)  indicating the number of test cases. For each test case, there is a number  n(0n1000)  on a line representing the number of water sources.  n  integers follow, respectively  a1,a2,a3,...,an , and each integer is in  {1,...,106} . On the next line, there is a number  q(0q1000)  representing the number of queries. After that, there will be  q  lines with two integers  l  and  r(1lrn)  indicating the range of which you should find out the biggest water source.
 

Output
For each query, output an integer representing the size of the biggest water source.
 

Sample Input
       
       
       
       
3 1 100 1 1 1 5 1 2 3 4 5 5 1 2 1 3 2 4 3 4 3 5 3 1 999999 1 4 1 1 1 2 2 3 3 3
 

Sample Output
       
       
       
       
100 2 3 4 4 5 1 999999 999999 1
 



RMQ裸题


ac代码:

#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#define MAXN 10010
#define INF 1000000000
using namespace std;
int A[MAXN];
int N, M;
int Amax[MAXN][50];
void RMQ_init()
{
    for(int i = 1; i <= N; i++)
        Amax[i][0] = A[i];
    for(int j = 1; (1<<j) <= N; j++)
    {
        for(int i = 1; i + (1<<j)-1 <= N; i++)
            Amax[i][j] = max(Amax[i][j-1], Amax[i+(1<<(j-1))][j-1]);
    }
}
int query(int L, int R)
{
    int k = 0;
    while((1<<(k+1)) <= R-L+1) k++;
    return max(Amax[L][k], Amax[R-(1<<k)+1][k]);
}
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d", &N);
        for(int i = 1; i <= N; i++)
            scanf("%d", &A[i]);
        RMQ_init();
        scanf("%d", &M);
        int x, y;
        while(M--)
        {
            scanf("%d%d", &x, &y);
            printf("%d\n", query(x, y));
        }
    }
    return 0;
}



你可能感兴趣的:(hdoj 5443 The Water Problem 【RMQ】)