HDU1035 Robot Motion【链式前向星】

Robot Motion


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7039    Accepted Submission(s): 3244

Problem Description
HDU1035 Robot Motion【链式前向星】_第1张图片
A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are 

N north (up the page)
S south (down the page)
E east (to the right on the page)
W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.
 
Input
There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.
 
Output
For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.
 
Sample Input
3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 
 
Sample Output
10 step(s) to exit

3 step(s) before a loop of 8 step(s)


题目大意:给你一个n*m的矩形图,每个位置上有'N'、'S'、'W'、'E',分别表示上下左右

四个方向。给你初始位置,如果能走出去了, 输出走出去的步数。

如果成环了,就输出环走一圈需要多少步。

思路:用链式前向星来做,把图看做是n个点,每个位置就是一条边,将边用链式前向星存

起来,每条边就有了一个序号,这个序号就是走的步数。然后,每走一步,我们就开始判

断是否在之前存储过这个位置(这条边),如果存储过就跳出循环,输出已存在这个位置的序

号(就是走圈前的步数),再输出总序号-已存在那个位置的序号(就是走圈的步数)。如果没有

存储过,就直接往下走,直到遇到存储过的,或者出图。若出图则输出总的序号。


#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
const int MAXN = 15;
const int MAXM = 150;

int head[MAXN];

struct EdgeNode
{
    int to;
    int w;
    int next;
};
EdgeNode Edges[MAXM];

char Map[15][15];

int main()
{
    int n,m,d,k;
    while(cin >> n >> m)
    {
        if(n==0 && m==0)
            break;
        cin >> d;
        for(int i = 0; i < n; i++)
            cin >> Map[i];

        memset(head,-1,sizeof(head));
        int i = 0;
        int j = d-1;
        int num = 0;
        while(1)
        {
            char c = Map[i][j];
            if(head[i] == -1)
            {
                Edges[num].to = j;
                Edges[num].w = 1;
                Edges[num].next = head[i];
                head[i] = num;
                num++;
            }
            else
            {
                for(k = head[i]; k != -1; k = Edges[k].next)
                {
                    if(Edges[k].to == j)//
                        break;
                }
                if(k == -1)
                {
                    Edges[num].to = j;
                    Edges[num].w = 1;
                    Edges[num].next = head[i];
                    head[i] = num;
                    num++;
                }
                else
                    break;
            }
            switch(c)
            {
            case 'N':
                i--;
                break;
            case 'W':
                j--;
                break;
            case 'E':
                j++;
                break;
            case 'S':
                i++;
                break;
            }
            if(i < 0 || j < 0 || i >= n || j >= m)
                break;
        }
        if(i < 0 || j < 0 || i >= n || j >= m)
             printf("%d step(s) to exit\n",num);
        else
            printf("%d step(s) before a loop of %d step(s)\n",k,num-k);
    }

    return 0;
}



你可能感兴趣的:(HDU1035 Robot Motion【链式前向星】)