http://acm.hdu.edu.cn/showproblem.php?pid=1863

这题也算是一道水题吧!我记得我以前是用Prim算法写的,现在用Kursal写一遍感觉还可以。。。。come on。。。


Problem Description
省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。经过调查评估,得到的统计表中列出了有可能建设公路的若干条道路的成本。现请你编写程序,计算出全省畅通需要的最低成本。



Input
测试输入包含若干测试用例。每个测试用例的第1行给出评估的道路条数 N、村庄数目M ( < 100 );随后的 N
行对应村庄间道路的成本,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间道路的成本(也是正整数)。为简单起见,村庄从1到M编号。当N为0时,全部输入结束,相应的结果不要输出。



Output
对每个测试用例,在1行里输出全省畅通需要的最低成本。若统计数据不足以保证畅通,则输出“?”。



Sample Input
3 3
1 2 1
1 3 2
2 3 4
1 3
2 3 2
0 100


Sample Output
3
?

Ac代码:

#include<iostream>
#include<string.h>
#include<algorithm>
#include<limits.h>
#define N 105
#define  FOR(i,s,t) for(int i=(s);i<=t;++i)
using namespace std;
int n,m;
int father[N];
struct edge{int x,y,len;
       }map[N];
typedef struct edge Node;
int cmp(const void *a,const void *b)
{   return ((Node*)a)->len>((Node*)b)->len?1:-1;
 }
void make_set()
{ FOR(i,1,n)
   father[i]=i;
}
int  find_set(int a)
{    while(a!=father[a])
           a=father[a];
      return a;
 }
 void Kursal()
 {     int sum=0,ans=0;
        bool flag=false;
      FOR(i,1,m)
      {
      int x=find_set(map[i].x);
       int y=find_set(map[i].y);
       if(x!=y)
       {    father[y]=x;
           sum+=map[i].len;
           ans++;
       }
       if(ans==n-1) {flag=true;break;}
      }
      if(flag)cout<<sum<<endl;
      else   cout<<"?"<<endl;
 }
 int main()
 {   while(cin>>m>>n)
       {     if(!m) break;
        make_set();
            FOR(i,1,m)
            cin>>map[i].x>>map[i].y>>map[i].len;
            qsort(map+1,m,sizeof(Node),cmp);
             Kursal();
       } return 0;
     }


你可能感兴趣的:(http://acm.hdu.edu.cn/showproblem.php?pid=1863)