A simple problem
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3133 Accepted Submission(s): 1144
Problem Description
Zty很痴迷数学问题.。一天,yifenfei出了个数学题想难倒他,让他回答1 / n。但Zty却回答不了^_^. 请大家编程帮助他.
Input
第一行整数T,表示测试组数。后面T行,每行一个整数 n (1<=|n|<=10^5).
Output
输出1/n. (是循环小数的,只输出第一个循环节).
Sample Input
Sample Output
0.5
0.3
0.142857
0.005952380
Author
yifenfei
Source
HDU 2008-10 Programming Contest
#include <stdio.h>
#include <string.h>
#define maxn 100002
bool vis[maxn];
int main()
{
int n, i, t, m;
scanf("%d", &t);
while(t--){
scanf("%d", &n);
if(n < 0){
printf("-"); n = -n;
}
if(n == 1){
printf("1\n"); continue;
}
memset(vis, 0, sizeof(bool) * n);
printf("0."); m = 1; vis[0] = 1;
while(!vis[m]){
vis[m] = 1; m *= 10;
printf("%d", m / n);
m %= n;
}
printf("\n");
}
return 0;
}