poj power strings

Power Strings
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 40441   Accepted: 16824

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

Waterloo local 2002.07.01


题目大意:求字符串s的最大循环次数

可以先求最小循环节,然后用长度/最小循环节

最小循环节=长度-末位失配

有一点需要特判:例如abcab,最大循环次数是1,但是如果直接用长度/最小循环节,答案是2.

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char s[10000003];
int t[4000003],len;
void calc_t()
{
  t[0]=-1; int j;
  for (int i=0;i<len;i++)
   {
   	 j=t[i];
   	 while (j!=-1&&s[i]!=s[j])
   	  j=t[j];
   	 t[i+1]=++j;
   }
}
int main()
{
  while (gets(s)&&strcmp(s,".")!=0)
   {
   	 len=strlen(s); memset(t,0,sizeof(t));
   	 calc_t();
   	 if (len%(len-t[len])==0)
   	  printf("%d\n",len/(len-t[len]));
   	 else
   	  printf("1\n");
   }
}


你可能感兴趣的:(poj power strings)