HDOJ 5406 CRB and Apple 树状数组优化DP


dp[i][j]表示一个人吃了第i个另一个人吃了第j个时最多可以吃多少个苹果.

dp[i][j]=max(max(dp[i][k]),max(dp[k][j]))+1

可以用树状数组快速的求出dp[i]的某一段的最大值



CRB and Apple

Time Limit: 12000/6000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 273    Accepted Submission(s): 79


Problem Description
In Codeland there are many apple trees.
One day CRB and his girlfriend decided to eat all apples of one tree.
Each apple on the tree has height and deliciousness.
They decided to gather all apples from top to bottom, so an apple can be gathered only when it has equal or less height than one just gathered before.
When an apple is gathered, they do one of the following actions.
1.  CRB eats the apple.
2.  His girlfriend eats the apple.
3.  Throw the apple away.
CRB(or his girlfriend) can eat the apple only when it has equal or greater deliciousness than one he(she) just ate before.
CRB wants to know the maximum total number of apples they can eat.
Can you help him?
 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:
The first line contains a single integer  N  denoting the number of apples in a tree.
Then  N  lines follow,  i -th of them contains two integers  Hi  and  Di  indicating the height and deliciousness of  i -th apple.
1 ≤  T  ≤ 48
1 ≤  N  ≤ 1000
1 ≤  Hi Di  ≤  109

 

Output
For each test case, output the maximum total number of apples they can eat.
 

Sample Input
   
   
   
   
1 5 1 1 2 3 3 2 4 3 5 1
 

Sample Output
   
   
   
   
4
 

Author
KUT(DPRK)
 

Source
2015 Multi-University Training Contest 10
 



/* ***********************************************
Author        :CKboss
Created Time  :2015年08月22日 星期六 08时49分41秒
File Name     :HDOJ5406.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>

using namespace std;

const int maxn=2000;

int n;
int arr[maxn],an;

struct Apple
{
	int h,d;
	void toString()
	{
		printf("h: %d,d: %d\n",h,d);
	}
}apple[maxn];

bool cmp(Apple x,Apple y)
{
	if(x.h!=y.h) return x.h>y.h;
	return x.d<y.d;
}

/*********************BIT*****************************/

int t[maxn];
int tree[maxn][maxn];

inline int lowbit(int x) { return x&(-x); }

void Update(int id,int p,int v)
{
	for(int i=p;i<maxn;i+=lowbit(i))
	{
		tree[id][i]=max(tree[id][i],v);
	}
}

int getMax(int id,int p)
{
	int ret=0;
	for(int i=p;i;i-=lowbit(i))
	{
		ret=max(ret,tree[id][i]);
	}
	return ret;
}

int main()
{
	//freopen("in.txt","r",stdin);
	//freopen("out.txt","w",stdout);

	int T_T;
	scanf("%d",&T_T);
	while(T_T--)
	{
		scanf("%d",&n);
		an=0;
		for(int i=1;i<=n;i++)
		{
			scanf("%d%d",&apple[i].h,&apple[i].d);
			arr[an++]=apple[i].d;
		}
		sort(arr,arr+an);
		an=unique(arr,arr+an)-arr;
		for(int i=1;i<=n;i++)
			apple[i].d=lower_bound(arr,arr+an,apple[i].d)-arr+1;

		sort(apple+1,apple+n+1,cmp);
			
		//for(int i=1;i<=n;i++) apple[i].toString();

		memset(tree,0,sizeof(tree));

		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
				t[j]=getMax(j,apple[i].d)+1;

			for(int j=1;j<=n;j++)
			{
				Update(j,apple[i].d,t[j]);
				Update(apple[i].d,j,t[j]);
			}
		}

		int ans=0;
		for(int i=1;i<=n;i++)
				ans=max(ans,getMax(i,an));

		printf("%d\n",ans);
	}
    
    return 0;
}



你可能感兴趣的:(HDOJ 5406 CRB and Apple 树状数组优化DP)